Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 09, 2025 - 18:00 BST
Scheduled
We will upgrading FileHound from Version 4.0 to Version 5.0 between 9th May, Starting from 18:00 and concluding 23:00 on Sunday 11th May. During these times, FileHound will be unavailable.
Posted May 08, 2025 - 16:18 BST
This scheduled maintenance affected: FileHound SaaS, FileHound API, FileHound Developer Instance, SendGrid API, and Freshdesk Incoming E-Mails.